Skip navigation.
Home
Java OpenDocument Reports

Software Requirements

JOOReports requires

  • A Java Runtime Environment version 5.0 or higher
  • Third-party libraries
  • OpenOffice.org 2.0 Writer to compose the templates
  • For use as a web application, a servlet 2.3 container such as Apache Tomcat 4.1 or higher

If you want to generate documents and reports in formats other than OpenDocument Text (ODT), i.e. for PDF, RTF and Word, a connection to an OpenOffice.org 2.0 instance running as a service is also required. See Starting OpenOffice.org as a service in the JOOConverter Guide for more details on this.